1) 查看開放端口
Linux: netstat -atn
Solaris: netstat -P tcp -f inet -an
2) 查看網卡/網絡狀態
Linux: ifconfig
Solaris: ifconfig -a 或者 dladm show-dev等
注1:Linux下每個網卡都是以eth0,eth1等來命名的,而Solaris則是以網卡驅動來命名的,如rtls0, iprb0, bge0, bge1,bnx0,e1000g1,nge1,xge0等,可以通過man來查看究竟是什麼網卡,比如:
# man iprb
注2:Linux在逐漸淘汰ifconfig命令,取而代之是功能更強調的iproute或者叫iproute2軟件包,主要命令有ip和tc.用ifconfig給網卡添加另外一個ip,命令如下:
# ifconfig eth0:0 192.168.3.15/24 broadcast 192.168.3.255
用ip如下:
# ip addr add 192.168.3.15/24 broadcast 192.168.3.255 dev eth0
3) 查看系統安裝的所有軟件包
Linux: rpm -qa 或者 dpkg-query -l
Solaris: pkginfo
4) 安裝軟件包
Linux: rpm -ivh stardict.rpm
Solaris: pkgadd -d `pwd` SUNWstardict
5) 卸載軟件包
Linux: rpm -e stardict
Solaris: pkgrm SUNWstardict
6) 查看軟件包的所有安裝文件
Linux: rpm -ql stardict
Solaris: pkgchk -l SUNWstardict | grep Pathname
注:在Solaris上還可以根據某一個文件來判斷該文件屬於哪一個安裝包
# pkgchk -lp /usr/share/stardict/sounds/menushow.wav
Pathname: /usr/share/stardict/sounds/menushow.wav
Type: regular file
Expected mode: 0644
Expected owner: root
Expected group: bin
Expected file size (bytes): 6250
Expected sum(1) of contents: 60494
Expected last modification: Jul 18 11:26:00 2006
Referenced by the following packages:
SUNWstardict
Current status: installed
今天發現rpm也可以實現此功能
# rpm -qf /bin/ls
coreutils-6.4-10