Description
將一個數組中的值按逆序重新存放。例如,原來的順序為8,6,5,4,1。要求改為1,4,5,6,8。
Input
輸入為兩行:第一行數組中元素的個數n(n大於1,n小於100)
第二行是n個整數,每兩個整數之間用空格分隔。
Output
輸出為一行:輸出逆序後數組的整數,每兩個整數之間用空格分隔。
Sample Input
5
8 6 5 4 1
Sample Output
1 4 5 6 8
參考代碼
- #include <iostream>
- #include <list>
- using namespace std;
- int main(){
- list<int>myList;
- int n,d;
- cin>>n;
- while(n --){
- cin>>d;
- myList.push_back(d);
- }
- myList.reverse();
- for(list<int>::iterator it = myList.begin();it != myList.end();++ it){
- cout<<*it<<" ";
- }
- cout<<endl;
- return 0;
- }