Description
班上有學生若干名,給出每名學生的年齡(整數),求班上所有學生的平均年齡,保留到小數點後兩位。
Input
第一行有一個整數n(1<= n <= 100),表示學生的人數。其後n行每行有1個整數,取值為15到25。
Output
輸出一行,該行包含一個浮點數,為要求的平均年齡,保留到小數點後兩位。
Sample Input
2
18
17
Sample Output
17.50Hint
要輸出浮點數、雙精度數小數點後2位數字,可以用下面這種形式:
printf("%.2f", num);
參考代碼
- #include <iostream>
- #include <iomanip>
- using namespace std;
- int main(){
- int n,i;
- float s,age;
- std::cin>>n;
- s = 0;
- for(i = 0;i < n;i ++){
- std::cin>>age;
- s += age;
- }
- std::cout<<std::fixed<<std::setprecision(2)<<s / n<<std::endl;
- return 0;
- }