Description
一個正整數,如果它能被7整除,或者它的十進制表示法中某個位數上的數字為7,則稱其為與7相關的數.現求所有小於等於n(n<100)的與7無關的正整數的平方和.
Input
輸入為一行,正整數n,(n<100)
Output
輸出小於等於n的與7無關的正整數的平方和
Sample Input
21
Sample Output
2336
參考代碼
- #include <iostream>
- #include <cmath>
- using namespace std;
- //judge whether the number contains 7
- bool find7(int n){
- while(n){
- if(n % 10 == 7){
- return true;
- }
- n /= 10;
- }
- return false;
- }
- int main(){
- int i,n,sum;
- //input section
- std::cin>>n;
- //calculate
- sum = 0;
- for(i = 1;i <= n;i ++){
- if(i % 7 != 0 && !find7(i)){
- sum += (int)pow(1.0 * i,2);
- }
- }
- //output section
- std::cout<<sum<<std::endl;
- return 0;
- }